Child pages
  • JMP Workshop
Skip to end of metadata
Go to start of metadata

Table of Contents (click to go directly to topic)


 

Datasets used in the workshop

In this workshop, we will use the "Big Class.jmp" dataset available in the "Help > Sample Data" directory in JMP:

  • To open this dataset, go to
    • Help>Sample Data>Examples for Teaching>Big Class

If you want to practice further with real data, the 2007-2008 National Health and Nutrition Examination Survey (NHANES) dataset is available. To download it, click NHANES_HCM757.jmp and choose to Save the dataset as NHANES_HCM757.jmp in a location or folder of your choice.

The "Help > Sample Data" directory in JMP contains several data tables from different domains, and some of these will also be used to illustrate examples.

Getting Started

  • Open JMP by double-clicking the desktop icon
  • Read the "Tip of the day"
  • JMP Starter and JMP Menus
  • Set Preferences
  • Open existing data files of several types (JMP, Excel, and other…)
  • Open the JMP dataset "Big Class"
    • Help>Sample Data>Examples for Teaching>Big Class
    • Video 1: Open JMP and explore menus
    • Video 2: Open datasets in JMP

JMP Help

  • Help Menu
  • Indexes: Statistics
  • Books: JMP Introductory Guide and more…
  • Sample Data
  • The “?” tool (Note: this feature does not work on Macs with the Snow Leopard operating system)
  • JMP User Community>JMP Blog
    • Video 3: JMP Help

Exploring the Data Table

  • Table attributes: Rows, columns, the 4 window panels, move columns, edit column names, resize, Column Info
  • Modeling Type
  • Data Type
  • Enter data in a new JMP dataset
    • Video 4: Data Tables

Sharing and Saving Your Work

  • Copy and paste: Select graphs and sections of a report and copy paste into Word, PowerPoint, etc...
    • Use Selection tool to select
    • Then right-click>Copy or Edit>Copy
    • In Word or Powerpoint (or other destination), Edit>Paste or Edit>Paste Special>Picture (Enhanced Metafile)
    • Save your analysis in scripts for re-submission
  • Video 5: Copying and pasting your work; Saving scripts so you can rerun them

Data Transformations (recoding, value labels, value ordering, formulas)

Right click on column or variable name → Column Info

Analyzing Data

Step 1: Univariate Analysis: Distribution

Look at variables or data items (also called columns) individually and appraise and describe their validity.

  • Analyze>Distributions  
    • How are the variables distributed? Are there outliers? Are the outliers invalid data points? Are there corrections that should and can be made?
    • Click on bars in graphics.
    • Right click on points for options to inspect them further.
    • Use lasso tool to choose a group of points.
    • Video 8: Distribution platform

Step 2: Bivariate Analysis: Fit Y by X

Look at the data items or variables in relationship to each other.

  • Analyze>Fit Y by X (This legend indicates on the lower left indicates the appropriate analysis based on the modeling type of the variables.)

  • Look at the relationship between 2 continuous variables
  • Look at the relationship between a continuous variables (Y) and a nominal variable (X)
  • Look at the relationship between 2 nominal variables
  • Look at the relationship between a nominal variable (Y) and a continuous variable (X)


      • Video 9:Fit Y by X platform

Step 3: Multivariate Analysis: Fit model

  • Analyze>Fit Model

Graph Menus

JMP Starter>Graph

Graph Menu (top bar)

Types of JMP Graphs

 

Chart

Scatterplot matrix

** The example graphs were made using the “Lipid” data:Help>Sample Data>Medical studies>Lipid data

Advanced graphic editing

Edit>Layout menu for more advanced graphics editing

Video 10: Graph Builder; Overlay Plots; Charts

Video 11: Scatterplot Matrix

Tables Menu (Subset, join, concatenate/append, stack, split, summarize/tabulate)

  • Subset
  • Join
  • Stack
  • Split
  • Tabulate 

Video 12: Tables Menu

Video 13: Tabulate

SAS Integration

  • SAS-JMP Comparison
  • See Column info in “NHANES_HCM757” dataset. Note SAS name and SAS label attributes