Skip to end of metadata
Go to start of metadata

 

The Batch Builder interface includes a menu bar, a tool bar, and three display panels. Context menus are also available by right-clicking on certain places within the GUI.

BB panels

In the following screen-shot of the interface, these components are labeled.

 

The following image shows more details about the project panel.

BB menu options

There are two sets of menus in BB:

  • Menus accessible from the menu toolbar at the top
  • Context menus accessible by right-clicking a particular item in the Project Panel on the left.

Menu toolbar

There are five menus that are accessible from the menu toolbar

Project menu

  • New – create new project
  • Open – open existing project
  • Close – close currently open project.
  • Save – save currently open project.
  • Save as … – save currently open project as a new project. This option saves the project configuration file "project.conf" (which contains all the project metadata settings entered in the Deposit Settings and Object Template) into a new directory. This is a useful option to use if you are planning to create a new project but the Deposit Settings information or/and Object Template information is going to be the same.
  • Exit – exit the program.

Batch menu

  • New – create a new object batch
  • Create descriptors & batch.xml – process a selected batch (note that a batch icon for a given batch needs to be selected in the Project Panel for this command to become active)
  • Stop creation of batch.xml – stops the creation of batch that is being currently processed (this command is only active while a batch is being processed)

Object menu

  • New – create new object (this command is only active if you first select a batch icon of a given batch in which object needs to be created in the BB Project Panel).
  • Create batch with objects from template – create a new batch of objects automatically from template. See the "Automatically build [object type] from template" section for a given object type in this Guide for procedure (E.g.: Automatically build still image objects from template).

View menu

  • Options – view the options dialog. See Setting options for more information.
  • Clear messages – clears messages from the messages panel.
  • Reload tree – reloads the Project Panel tree (useful when you want to see the latest changes made in the project panel)
  • Toolbar – show / hide toolbar with action icons .

 

Help menu

  • About – information about Batch Builder version and build date.
  • Contents – link to Batch Builder 2 User Guide.

Context menus

There are six types of context menus that are available in BB2 – all from the Project Panel:

  1. Project context menu
  2. Object template context menu
  3. Object template directory context menu
  4. Batch context menu
  5. Object context menu
  6. Object directory context menu

These context menus are described below in more detail.

Project context menu

Right-clicking on the project icon (P) will open a context menu that allows you to create a new batch.


Object template context menu

Right-clicking on the object template icon (T) will open a menu where you can add a new directory or automatically create a batch of objects from template.


Object template directory context menu

Right-clicking on the directory icon will open a context menu where you can add a new directory nested inside the present one or remove a directory.


Batch context menu

Clicking on the batch icon (B) opens a context menu where you can create a new object, process the batch and remove the batch.


Object context menu

Right-clicking on the object icon (O) will open a context menu where you can add new directory, rename an object, remove an object, and Set Aleph or Alma ID


Note that the right way to rename an object after it was created in BB is to use this menu option. Renaming the object directory on disk outside BB is not sufficient and will lead to errors when trying to open the project in BB afterward.

Object directory context menu

Right-clicking on the directory icon will open a context menu where you can add a directory (nested inside the current directory) or remove the current directory

On this page:

  • No labels

1 Comment

  1. Missing images in "About BB panels" section of ch2.  --julie